On Tue, Nov 27, 2012 at 9:11 AM, Graham Menhennitt
<graham / menhennitt.com.au> wrote:
> On 23/11/2012 00:56, Robert Klemme wrote:

>> Why don't you use the Ruby version from the repo?  cygwin switched to
>> 1.9 a while back:
>>
>> $ ruby -v
>> ruby 1.9.3p327 (2012-11-10 revision 37606) [i386-cygwin]
>>
> Thanks for that, Robert.

You're welcome.

> How do they (the CygWin guys) build it? They must do something to fix
> that error. Why can't we (the Ruby guys) do the same thing (it's in a
> #ifdef CYGWIN, so it won't affect anything else)?

You can download the sources.  Maybe that'll help.  You could also
diff vs. the default sources.

> I'm trying to build a CygWin program with an embedded Ruby interpreter.
> It builds and starts running but exits immediately. I can't debug it in
> Cygwin GDB - it just hangs whenever I do a 's' or 'n' command.

Ah.  Then of course you must build it.

Kind regards

robert

--
remember.guy do |as, often| as.you_can - without end
http://blog.rubybestpractices.com/