Lyle Johnson wrote in post #659639:

>>  extconf.rb:31:in `find_installed_fox_version': couldn't find FOX header
>> files (RuntimeError) from extconf.rb:183
>
> This error (which, unfortunately, is very vague) is indicating that it
> couldn't find an installation of FOX on your computer. FXRuby is just
> a Ruby layer on top of FOX, and so you need to have FOX installed
> before you can even attempt to install FXRuby.
>
> Since you're running Ubuntu Linux, you should be able to just install
> FOX from a package:
>
>     sudo apt-get install libfox-1.6-dev

This is right on the money.  I had a feeling there was some prerequisite 
that fxruby required, but not knowing anything about it and not being a 
Linux guru, I had no idea what to look for.

Thanks, Lyle!  You've helped me resolve a problem that's been bothering 
me for several days now.

-- The Beerslayer

-- 
Posted via http://www.ruby-forum.com/.