I'm trying to launch Webdriver via an Ocra exe which works on all the
PCs I've tried except one particular one.

It works on WinXP 32 bit, and Win7 32 and 64 bit. The computer that's
getting this error is 64 bit Win7.

It seems to be failing when trying to load Webdriver. The only
suggestions I've been able to find seem to be about 64 bit processes
being incompatible with 32 bit, or possibly having a space in a path. I
haven't been able to find either of these as it seems to be a
peculiarity with that particular PC, and I can't find anything different
about it apart from this error.

C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require': 193: %1 is not a valid Win32 application.   -
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/1.9.1/i386-mingw32/openssl.so
(LoadError)
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/1.9.1/openssl.rb:17:in
`<top (required)>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/1.9.1/net/https.rb:22:in
`<top (required)>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver/remote/http/default.rb:1:in
`<top (required)>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver/remote.rb:9:in
`<top (required)>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver/firefox/bridge.rb:6:in
`<module:Firefox>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver/firefox/bridge.rb:3:in
`<module:WebDriver>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver/firefox/bridge.rb:2:in
`<module:Selenium>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver/firefox/bridge.rb:1:in
`<top (required)>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver/firefox.rb:12:in
`<top (required)>'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver/common/driver.rb:31:in
`for'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/selenium-webdriver-2.25.0/lib/selenium/webdriver.rb:65:in
`for'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/lib/ruby/gems/1.9.1/gems/watir-webdriver-0.6.1/lib/watir-webdriver/browser.rb:35:in
`initialize'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/src/Reallocatev0.6.rbw:262:in
`new'
  from
C:/Users/epos2/AppData/Local/Temp/ocr74C2.tmp/src/Reallocatev0.6.rbw:262:in
`<main>'

http://www.technipages.com/error-193-1-is-not-a-valid-win32-application.html

-- 
Posted via http://www.ruby-forum.com/.