why I am getting this error? and how to fix it?

gem --version

[/usr/lib/ruby/gems/1.8/specifications/treetop-1.4.11.gemspec] isn't a
Gem::Specification (NilClass instead).
[/usr/lib/ruby/gems/1.8/specifications/i18n-0.6.1.gemspec] isn't a
Gem::Specification (NilClass instead).
[/usr/lib/ruby/gems/1.8/specifications/polyglot-0.3.3.gemspec] isn't a
Gem::Specification (NilClass instead).
[/usr/lib/ruby/gems/1.8/specifications/mail-2.4.4.gemspec] isn't a
Gem::Specification (NilClass instead).
[/usr/lib/ruby/gems/1.8/specifications/mime-types-1.19.gemspec] isn't a
Gem::Specification (NilClass instead).
1.8.24

-- 
Posted via http://www.ruby-forum.com/.