On Sep 24, 2012, at 5:30 PM, Ja Tse <lists / ruby-forum.com> wrote:

> Hi All
> 
> I have just created a new cucumber test framework and this is what it
> looks like.
> 
> ~/cucumber/cucumber_sinatra$> tree
> .
> изибиб Gemfile
> изибиб Gemfile.lock
> изибиб features
> ив   изибиб fruit_list.feature
> ив   изибиб step_definitions
> ив   ижибиб support
> ив       ижибиб env.rb
> изибиб lib
> ив   ижибиб fruit_app.rb
> ижибиб spec
> 
> 5 directories, 5 files
> 
> And the gem file includes the folowing gems:
> 
> source :rubygems
> 
> gem 'sinatra'
> gem 'json'
> 
> group :test do
>  gem 'cucumber'
>  gem 'rspec'
>  gem 'rack-test'
> end
> 
> 
> And I have done, bundle install many times after deleting the old
> Gemfile.lock.  And all looks OK.
> 
> ~/cucumber/cucumber_sinatra$> bundle install
> Fetching source index for http://rubygems.org/
> Using builder (3.1.3)
> Using diff-lcs (1.1.3)
> Using json (1.7.5)
> Using gherkin (2.11.2)
> Using cucumber (1.2.1)
> Using rack (1.4.1)
> Using rack-protection (1.2.0)
> Using rack-test (0.6.1)
> Using rspec-core (2.11.1)
> Using rspec-expectations (2.11.3)
> Using rspec-mocks (2.11.3)
> Using rspec (2.11.0)
> Using tilt (1.3.3)
> Using sinatra (1.3.3)
> Using bundler (1.0.15)
> Your bundle is complete! Use `bundle show [gemname]` to see where a
> bundled gem is installed.
> 
> 
> However if I try to run cucumber I get the following error.
> 
> ~/cucumber/cucumber_sinatra$> bundle exec cucumber features/
> Could not find builder-3.1.3 in any of the sources
> Run `bundle install` to install missing