Eric Christopherson wrote in post #1076323:
> On Mon, Sep 17, 2012 at 2:04 AM, GPad <peterpan105105 / yahoo.it> wrote:
>> Hi,
>> I have VS installed but the problem seems related to the generation of code
>> with an installed version of ruby (that I have ...)
>
> Gianluca, Ruby doesn't build with VS (that I know of). You'll have to
> install a version of Ruby from http://rubyinstaller.org/ and then
> clone the repository at https://github.com/oneclick/rubyinstaller and
> follow its directions.


While you can build part of the core of ruby with VS (I do it with
WinSDK 7.1 on Win7 32bit), one of the main issues is the dependency
libraries and keeping everything using the same msvcrt version. I know
of one person who creatively solves this puzzle; his solution is
documented in our RubyInstaller ML.

That said, it's so much easier to either download one of our pre-built
installers, or build from source by cloning our repo.

We make it almost trivial to build a full ruby from source with our
build recipes. The recipes download everything the build needs into a
sandbox and builds with an internal (selectable) mingw/mingw-w64 based
toolchain.

We even give you the capability to easily build tweaked versions. For
example, say you've cloned our repo to `C:\projects\rubyinstaller` and
you've cloned the ruby repo to `C:\projects\ruby-core` and you want to
build `trunk` using the recently announced 32bit TDM/MinGW 4.7.1
toolchain (we call 'em
DevKit's!).

One way to build is:

  cd c:\projects\rubyinstaller
  rake ruby19 local=c:\projects\ruby-core dkver=tdm-32-4.7.1

That's not so hard is it?

Once the build finishes you can test it all, grab the built artifacts
from the sandbox or tell the recipes to bundle everything up into a
convenient archive, and more.

We even have nice Jenkins-based CI server and goodies at
http://ci.rubyinstaller.org/

So, if you want to build Ruby for Windows on Windows (with or without
tweaks), we make it easy to do. You don't need to cross-compile from
Linux, even though you can if you'd like.

This should be enough to get you started. If it's not, swing by our ML
at

https://groups.google.com/forum/?fromgroups#!forum/rubyinstaller

and Luis, myself, or one of the other awesome RubyInstaller contributors
will try to help you out.

Jon

---
Fail fast. Fail often. Fail publicly. Learn. Adapt. Repeat.
http://thecodeshop.github.com | http://jonforums.github.com/
twitter: @jonforums

-- 
Posted via http://www.ruby-forum.com/.