Ryan Davis <ryand-ruby / zenspider.com> wrote:

> On Sep 14, 2012, at 16:20 , Matt Neuburg <matt / tidbits.com> wrote:
> 
> > <sto.mar / web.de> wrote:
> > 
> >> What would be the least painful option, in your opinion:
> > 
> > It happens that I just did this (install 1.9.3 on Snow Leopard and
> > Mountain Lion machines), and here's how:
> > 
> > http://www.apeth.com/nonblog/stories/ruby193.html
> 
> I disagree with this route. As you can see, 
> homebrew makes things simpler for you:
> 
>   depends_on :autoconf if build.head?
>   depends_on 'pkg-config' => :build
>   depends_on 'readline'
>   depends_on 'gdbm'
>   depends_on 'libyaml'
> 
> boom. done. esp for a student... why should they bother with 
> something more complex as well as error prone?

I see no error prone-ness. I've now done this on four different Mac OS X
installations using representing three different systems. I can do it
reliably with my eyes closed. m.

-- 
matt neuburg, phd = matt / tidbits.com <http://www.tidbits.com/matt/>
A fool + a tool + an autorelease pool = cool!
AppleScript: the Definitive Guide - Second Edition!
http://www.tidbits.com/matt/default.html#applescriptthings