I know it would be best to upgrade to latest version of Ruby, but since =
the scripts is planed to be running on multiple server it would be =
easier to go get it working with the current version of Ruby.

I tried installing an older version of ibm_db but it keeps trying to =
install multi_json for dependency, is there a way to give a no =
dependency for gem install? Since multi_json requires Rubygems 1.3.6 and =
ruby 1.8.5 is only working with Rubygems 1.3.5 I can't install it.

=46rom where is the dependency defined? Both my version of Rubygems and =
ibm_db are older than the oldest version of multi_json, so Im a bit =
mystified on where the the dependency is coming from?

/Emil

On 27 Jul, 2012, at 16:35 , Chris Hulan <chris.hulan / gmail.com> wrote:

> IMHO upgrading to a more current Ruby is your best bet
>=20
> However, if that's not possible you could specify an older version of
> the ibm_db gem that aligns with the version of Ruby you have
> Looks like Ruby 1.8.5 was last updated in 2008, so maybe ibm_db 0.9.3
> - 1.0.1 will work
>=20
> cheers
> Chris
>=20