You are probably switching ruby versions and reading incompatible marshal fi=
les?

See what file this is trying to read and go from there.

On Jul 23, 2012, at 9:31, Joel Pearson <lists / ruby-forum.com> wrote:

> C:/Ruby193/lib/ruby/gems/1.9.1/gems/addressable-2.3.1/lib/addressable/idna=
/pure.
> rb:323:in `load': marshal data too short (ArgumentError)
>        from