Hello, i'm just getting started with ruby and have hit a wall attempting
to use some simple gems.

Source:
#! /usr/bin/ruby
require 'flt'
puts DecNum(22.1138)
---------------------
thats it!

right now it spits out this error:
> ruby -T test.rb
/usr/lib/ruby/1.9.1/rubygems/specification.rb:268:in `[]': Insecure
operation - [] (SecurityError)
  from /usr/lib/ruby/1.9.1/rubygems/specification.rb:268:in `block in
_all'
  from /usr/lib/ruby/1.9.1/rubygems/specification.rb:267:in
`reverse_each'
  from /usr/lib/ruby/1.9.1/rubygems/specification.rb:267:in `_all'
  from /usr/lib/ruby/1.9.1/rubygems/specification.rb:409:in `each'
  from /usr/lib/ruby/1.9.1/rubygems/specification.rb:441:in `find'
  from /usr/lib/ruby/1.9.1/rubygems/specification.rb:441:in
`find_by_path'
  from /usr/lib/ruby/1.9.1/rubygems.rb:203:in `try_activate'
  from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:58:in `rescue in
require'
  from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
  from test.rb:3:in `<main>'

with some configurations i've gotten:
> ruby -T test.rb
test.rb:7:in `<main>': undefined method `DecNum' for main:Object
(NoMethodError)

i'm using ubuntu 12.04, and installed ruby + rubygems from the
repository, purged it, tried RVM, tried ruby1.9 from the repository's.
I've spent the last 3 days scouring the Internet for a solution, found a
few older bug reports about it the issue, but no answers.  90% of the
hits i get are about security issues in rails applications, which i
really dont care about as i'm not messing with web-apps yet.

any help at all is appreciated, Thanks,
Locky

-- 
Posted via http://www.ruby-forum.com/.