Hi,

As far as I understand, Ruby 1.9 has native threads, but they're blocked 
by the Global Interpreter Lock.

So they should work like you want them to.

-- 
Posted via http://www.ruby-forum.com/.