On Jun 17, 2012, at 03:41, pahnin s. wrote:
> Hi, I'm trying to install libxml-ruby 1.1.4, but its giving error, I
> have searched on google tried all types of solutions I found, but it
> still giving the same error
>=20
> Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native
> extension.
>=20
>        /usr/bin/ruby extconf.rb
> extconf.rb:6: stack level too deep (SystemStackError)
>=20
>=20
> Gem files will remain installed in
> /home/phanindra/.gem/ruby/1.9.1/gems/libxml-ruby-1.1.4 for inspection.
> Results logged to
> =
/home/phanindra/.gem/ruby/1.9.1/gems/libxml-ruby-1.1.4/ext/libxml/gem_make=
.out

Why are you using such an old version of libxml-ruby?  1.1.3 (the last =
tag in the 1.1 series) has a glaringly obvious bug with that top-level =
method_missing:

$ ruby -e 'def method_missing(*) p :called end; "".missing'
:called

I doubt 1.1.4 is any different.  Newer versions don't seem to have this =
extconf.rb bug.

Why aren't you using nokogiri?=