> It'd be more idiomatic to rename the methods [] and []=.

I like it.  It's apparent that there are a number of ways to skin this 
cat.  I'm just glad that I now understand the issue.  As I said, I was 
tearing my hair out.  Thanks to all.

     ... doug

-- 
Posted via http://www.ruby-forum.com/.