I am trying to install a gem 'cucumber-rails' version 1.2.1 on a Windows
7 Machine with Ruby version 1.9.3. Even after multiple tries I could not
install. This is the error which I see when ever I tried.
I have DevKit working with updated cinfig.yml.

Any help is greatly appreciated.
Thanks in advance.


C:\Users\venkatac>gem install cucumber-rails -v '1.2.1'
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
The system cannot find the path specified.
ERROR:  Error installing cucumber-rails:
        ERROR: Failed to build gem native extension.

        C:/Ruby193/bin/ruby.exe extconf.rb
checking for ffi.h... no
checking for ffi.h in /usr/local/include... no
checking for rb_thread_blocking_region()... yes
checking for ruby_native_thread_p()... yes
checking for rb_thread_call_with_gvl()... yes
creating extconf.h
creating Makefile


Gem files will remain installed in
C:/Ruby193/lib/ruby/gems/1.9.1/gems/ffi-1.0.11 for inspection.
Results logged to
C:/Ruby193/lib/ruby/gems/1.9.1/gems/ffi-1.0.11/ext/ffi_c/gem_make.out

Attachments:
http://www.ruby-forum.com/attachment/7428/GemError.png


-- 
Posted via http://www.ruby-forum.com/.