Hi Wybo, J and folks,

@J,

Thank you for forwarding this post to Shoes-ML.
I didn't notice this post in ruby-talk ML. xx-P


@Wybo,

What platform are you using?

> According to http://rubydoc.info/gems/green_shoes/1.1.358/frames,
> all you need is
> Ruby 1.9 or above
> Gems 1.5 or above
> ruby-gtk2 package 0.90.7 or above
Ah, sorry. This information may not be correct for now. xx-P

You wrote:
> I have:
> Ruby 1.9.3
> Gem  1.8.11
> ruby-gtk2 1.0.3-1

And got this error:
> Gem files will remain installed in /var/lib/gems/1.9.1/gems/glib2-1.1.3
> for inspection.
> Results logged to
> /var/lib/gems/1.9.1/gems/glib2-1.1.3/ext/glib2/gem_make.out

I'm not sure, but that looks like a conflict of glib2 version.
Could you try to use the latest gtk2 and dependent gems?
I think the latest version is 1.1.3.

http://rubygems.org/gems/gtk2

If `gem install green_shoes` doesn't work well, try out doing first `gem
install gtk2`, then `gem install green_shoes`.

ashbb