> C:/Program Files/Ruby192/lib/ruby/1.9.1/mkmf.rb:368:in `try_do': The
> complier failed to generate an executable file. (RuntimeError)
> You have to install development tools first.

The very first thing you should do is reinstall both Ruby and the DevKit
to a directory without spaces, say c:\Ruby192 and c:\DevKit. Don't 
forget to configure the Devkit and run it's `dk.rb` install script.

I'm guessing you've already read our wiki pages, but if not, start with
these:

https://github.com/oneclick/rubyinstaller/wiki/Development-Kit
https://github.com/oneclick/rubyinstaller/wiki/Troubleshooting

If none of this works, create a detailed gist with more system specifics
and drop a note of what you're trying to `bundler install` over at
http://groups.google.com/group/rubyinstaller

Jon

-- 
Posted via http://www.ruby-forum.com/.