MIke,
I took a look but it is all greek to me. Not sure what Xcode 4.3 is or 
many of the other programs discussed in the blog.

Per the error message I received when the install failed, I have 
attempted to read the two logs (configure and make) by pasting the 
following in bash:

/Users/bobbaird001/.rvm/log/ruby-1.9.3-p125/yaml/configure.log

However, it tells me I don't have permissions (heck it is my mac and I 
am bobbaird001 :-)

I tried going through GUI to find the file in that directory, but .rvm 
doesn't appear (I assume it is hidden and don't have a clue as to how to 
unhide).  I am learning UNIX in parallel but haven't found anything yet 
that will help me out of this mess.

So, I am kind of at a real loss here.  I had no idea (especially on a 
Mac) that upgrading an application would be this problematic.

BTW, any advice as to where I should start on this journey given that I 
clearly don't have the knowledge to even begin.  I have taught myself 
PHP, MySQL, ASP and VB script so I am not a dummy but Unix and Ruby are 
new.

Bob

-- 
Posted via http://www.ruby-forum.com/.