If you are using Xcode 4.3 then you might want to look at this page:

http://jfire.io/blog/2012/03/02/xcode-4-dot-3-homebrew-and-ruby/

It saved me a lot of grief!  If you are using homebrew =
(http://mxcl.github.com/homebrew/) the apple command line tools then

brew install autoconf automake

will get you the tools you need. =20

Hope this helps,

Mike


On 2012-04-02, at 6:14 PM, Bob Baird wrote:

> Hassan (et al),
> Thank you.  I figured a lot of it out (trial and error)and was able to=20=

> eventually download and install RVM.  I then was able to download and=20=

> attempted to install Ruby 1.9.3 using RVM but got some errors below =
and=20
> therefore it failed to install.
>=20
> I am a UNIX beginner (like 4 hours a go :-) but it seems to me that=20
> things didn't' go in the right place according to the error for the=20
> configure.log and the error for the make.log.  It says to read them =
but=20
> I am such a newbie I don't yet know how to do that.  Is there =
something=20
> simple I should have done to prevent the errors before I attempted the=20=

> Ruby install?
> Bob
> =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
>=20
> ROBERTs-iMac:~ bobbaird001$ rvm install ruby 1.9.3
> Fetching yaml-0.1.4.tar.gz to /Users/bobbaird001/.rvm/archives
>  % Total    % Received % Xferd  Average Speed   Time    Time     Time=20=

> Current
>                                 Dload  Upload   Total   Spent    Left=20=

> Speed
> 100  460k  100  460k    0     0   167k      0  0:00:02  0:00:02 =
--:--:--=20
> 284k
> Extracting yaml-0.1.4.tar.gz to /Users/bobbaird001/.rvm/src
> Configuring yaml in /Users/bobbaird001/.rvm/src/yaml-0.1.4.
> Error running ' ./configure --prefix=3D"/Users/bobbaird001/.rvm/usr"  =
',=20
> please read=20
> /Users/bobbaird001/.rvm/log/ruby-1.9.3-p125/yaml/configure.log
> Compiling yaml in /Users/bobbaird001/.rvm/src/yaml-0.1.4.
> Error running 'make ', please read=20
> /Users/bobbaird001/.rvm/log/ruby-1.9.3-p125/yaml/make.log
>=20
>=20
> Database file /Users/bobbaird001/.rvm/config/packages does not exist.
>=20
> /Users/bobbaird001/.rvm/scripts/functions/build: line 28: --version:=20=

> command not found
> Installing Ruby from source to:=20
> /Users/bobbaird001/.rvm/rubies/ruby-1.9.3-p125, this may take a while=20=

> depending on your cpu(s)...
>=20
> ruby-1.9.3-p125 - #fetching
> ruby-1.9.3-p125 - #downloading ruby-1.9.3-p125, this may take a while=20=

> depending on your connection...
>  % Total    % Received % Xferd  Average Speed   Time    Time     Time=20=

> Current
>                                 Dload  Upload   Total   Spent    Left=20=

> Speed
> 100 9505k  100 9505k    0     0  82982      0  0:01:57  0:01:57 =
--:--:--=20
> 81732
> ruby-1.9.3-p125 - #extracting ruby-1.9.3-p125 to=20
> /Users/bobbaird001/.rvm/src/ruby-1.9.3-p125
> ruby-1.9.3-p125 - #extracted to=20
> /Users/bobbaird001/.rvm/src/ruby-1.9.3-p125
> Applying patch 'xcode-debugopt-fix-r34840' (located at=20
> =
/Users/bobbaird001/.rvm/patches/ruby/1.9.3/p125/xcode-debugopt-fix-r34840.=
diff)
> rvm requires autoreconf to install the selected ruby interpreter =
however=20
> autoreconf was not found in the PATH.
> ROBERTs-iMac:~ bobbaird001$ ruby -v
> ruby 1.8.7 (2010-01-10 patchlevel 249) [universal-darwin11.0]
> ROBERTs-iMac:~ bobbaird001$
>=20
> --=20
> Posted via http://www.ruby-forum.com/.

--=20

Mike Stok <mike / stok.ca>
http://www.stok.ca/~mike/

The "`Stok' disclaimers" apply.