On my lion I had to install Xcode 4.3.1 And then after that the Xcode command line tools. I can't recall the exact error I was getting but following thevm install and build instructions all was well. Hope I helped

Sent from my iPhone

On Mar 27, 2012, at 1:20 PM, Ryan Davis <ryand-ruby / zenspider.com> wrote:

> 
> On Mar 27, 2012, at 10:11 , David Souza wrote:
> 
>> Just wondering if anyone has seen this before... now matter what I do on
>> one of my systems I always get this error:
>> 
>> adsl:~ dsouza$ rvm use 1.9.3
>> Using /Users/dsouza/.rvm/gems/ruby-1.9.3-p125
>> adsl:~ dsouza$ rvm docs generate
>> 'rvm docs ...' requires ruby sources to be available, run `rvm reinstall
>> ruby-1.9.3-p125
>> 
>> 
>> I have done a rm -rf ~/.rvm/ and completely re-installed from scratch as
>> well as done the rvm reinstall as well...
>> 
>> 
>> just wondering if anyone has seen this before... it only happened on 1
>> of my 3 systems... The other 2 systems (Mac OS X Lion 10.7.3) all worked
>> fine.
> 
> Never seen that before... I'd look at env vars that are different... but in the meantime, rsync is your friend.
> 
> 
>