I was trying to just do a CLI short (very short) script with activerecord 
and sqlite3, and in tracing back some errors ended at:

thufir@dur:~$ 
thufir@dur:~$ gem search rmagic -r

*** REMOTE GEMS ***

compass-rmagick-engine (0.0.2)
hornetseye-rmagick (0.5.0)
jdeerhake-compass-rmagick-engine (0.0.3)
rdp-rmagick (0.0.0)
rmagick (2.13.1)
rmagick4j (0.3.7, 0.3.4 java)
rmagick_captcha (0.6.2)
thufir@dur:~$ 
thufir@dur:~$ 
thufir@dur:~$ 
thufir@dur:~$ 
thufir@dur:~$ gem install rmagick  --no-rdoc --no-ri
Building native extensions.  This could take a while...
ERROR:  Error installing rmagick:
	ERROR: Failed to build gem native extension.

        /home/thufir/.rvm/rubies/ruby-1.9.3-p125/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
extconf.rb:128: Use RbConfig instead of obsolete and deprecated Config.
checking for gcc... yes
checking for Magick-config... no
Can't install RMagick 2.13.1. Can't find Magick-config in /home/
thufir/.rvm/gems/ruby-1.9.3-p125/bin:/home/thufir/.rvm/gems/ruby-1.9.3-
p125@global/bin:/home/thufir/.rvm/rubies/ruby-1.9.3-p125/bin:/opt/
ActiveTcl-8.5/bin:/home/thufir/.rvm/gems/ruby-1.9.3-p125/bin:/home/
thufir/.rvm/gems/ruby-1.9.3-p125@global/bin:/home/thufir/.rvm/rubies/
ruby-1.9.3-p125/bin:/home/thufir/.rvm/bin:/usr/lib/lightdm/lightdm:/usr/
local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
	--with-opt-dir
	--with-opt-include
	--without-opt-include=${opt-dir}/include
	--with-opt-lib
	--without-opt-lib=${opt-dir}/lib
	--with-make-prog
	--without-make-prog
	--srcdir=.
	--curdir
	--ruby=/home/thufir/.rvm/rubies/ruby-1.9.3-p125/bin/ruby


Gem files will remain installed in /home/thufir/.rvm/gems/ruby-1.9.3-p125/
gems/rmagick-2.13.1 for inspection.
Results logged to /home/thufir/.rvm/gems/ruby-1.9.3-p125/gems/
rmagick-2.13.1/ext/RMagick/gem_make.out
thufir@dur:~$ 
thufir@dur:~$ 
thufir@dur:~$ type rvm | head -1
rvm is a function
thufir@dur:~$ 
thufir@dur:~$ rvm --version

rvm 1.10.3 by Wayne E. Seguin <wayneeseguin / gmail.com>, Michal Papis 
<mpapis / gmail.com> [https://rvm.beginrescueend.com/]

thufir@dur:~$ 
thufir@dur:~$ ruby --version
ruby 1.9.3p125 (2012-02-16 revision 34643) [i686-linux]
thufir@dur:~$ 
thufir@dur:~$ gem --version
1.8.19
thufir@dur:~$



Now, it looks like I just use apt-get to install imagemagick on Ubuntu 
11.10, but that seems off, in that gems should be system independent, to 
my understanding.

This gem requires that I install a non-gem piece of software?





thanks,

Thufir