On 02/23/2012 07:44 AM, Ruby Student wrote:
> Hello Team,
> 
> I am trying to install *mechanize* but it is failing. Any help will be
> appreciated.
> Here are the details:
> 
> *OS*: Red Hat Enterprise Linux Workstation release 6.2 (Santiago)
> *Ruby*:
> ruby -v
> ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux]
> 
> It complains that that library:*libxslt is missing.* However, the
> library IS installed:
> #*rpm -qa | grep -i libxslt*
> libxslt-python-1.1.26-2.el6.x86_64
> libxslt-1.1.26-2.el6.x86_64

When you see errors or notifications like what you're getting, it means
that you need the development packages installed.  You only have the
runtime packages, and those don't include everything that is required to
compile a native extension such as mechanize.

I believe the package you need to install is libxslt-devel.

-Jeremy