On Wed, Feb 1, 2012 at 2:47 PM, Robert Klemme
<shortcutter / googlemail.com> wrote:
> since a few day I cannot compile Ruby 1.9.3 under Cygwin. =A0I haven't
> found the reason so far. =A0Could be caused by a cygwin update or
> something else. Libs are all in place. =A0In fact this compile worked
> without issues in the past.

I finally found out what went wrong: apparently McAfee AV interfered
with the build process and prevented execution.  I did not connect
this because there was no immediate feedback to the build and the log
message indicates that this is just a warning without effects.  In
case you are interested, here are the details:

Event Type:	Information
Event Source:	McLogEvent
Event Category:	None
Event ID:	257
Date:		21.02.2012
Time:		09:04:54
User:		NT AUTHORITY\SYSTEM
Computer:	XXXXXXXXXXX
Description:
W=FCrde durch Zugriffsschutzregel blockiert werden (Regel befindet sich
im Warnmodus) (Common - Standardschutz:Ausf=FChren von Dateien im
Temp-Ordner f=FCr h=E4ufig genutzte Programme verhindern).

Description translated means something like: "Would be blocked by
access control rule (rule is in warning mode). (Common - basic
protection: prohibit execution of files in temp folder for common
programs)."

Despite the error message apparently execution _was_ blocked.  My fix
was as easy as to provide a different temp dir:

$ mkdir tmp
$ TMP=3D"$PWD/tmp" make install

Kind regards

robert

--=20
remember.guy do |as, often| as.you_can - without end
http://blog.rubybestpractices.com/