Just went back to it to get a copy of the errors, which were extensive, 
and all related to the YAML module, and it is now working correctly. It 
has been throwing errors since Wednesday, when I updated Ruby!!!
Thanks all.

-- 
Posted via http://www.ruby-forum.com/.