options = {
    'list_cars' => proc { list_cars }, 'lc' => 'list_cars',
    'list_horses' => proc { list_horses }, 'lh' => 'list_horses',
    'list_plants' => proc { list_plants }, 'lp' => 'list_plants',
    'help' => proc { show_help }
  }
  options.default = proc { show_help }
  options

Hmm.

The problem is that I would be forced to use procs?

I don't like that.

I also feel as if the way to use aliases as in your example is VERY 
cumbersome with hashes.

  when 'list_cars','lc'

Is much more readable.



> Or a way to programmatically access your methods:

> self.methods # => ["list_cars", "list_whatever", "list_plants", ...]

> A better way would probably be:
> self.class.public_instance_methods(false)

Hmm actually, you gave me a very good idea. I will probably toy a little 
bit with that - I could follow with a convention of methods for 
instance, or otherwise denote primary methods. Thanks Ryan!


By the way, also thanks to you Yossef Mendelssohn. Even if I initially 
disliked your suggestion, I will continue to play with it and test it 
slowly (which may help me to convince myself that it may not be so ugly 
as it appears to be on first glance).

Thanks!

-- 
Posted via http://www.ruby-forum.com/.