Well, the second is clearer to read line by line. But I find it easier
to grasp at a glance what the first one is doing as there's less noise
from variable names. A middle way of course would be to use
abbreviated variable names, such as 'args', 'opts', etc.