I am using rails 2.2.2 with ruby 1.8.7.
When i start server, this is the error that i receive:

E:\xop\xopweb>ruby script/server
=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails 2.2.2 application starting on http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
Exiting
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/depende
ncies.rb:142:in `load_without_new_constant_marking': no such file to
load -- mon
grel_rails (MissingSourceFile)
        from
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_su
pport/dependencies.rb:142:in `load'
        from
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_su
pport/dependencies.rb:521:in `new_constants_in'
        from
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_su
pport/dependencies.rb:142:in `load'
        from
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/commands/servers/
mongrel.rb:64
        from
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
        from
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`require'
        from
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_su
pport/dependencies.rb:153:in `require'
        from
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_su
pport/dependencies.rb:521:in `new_constants_in'
        from
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_su
pport/dependencies.rb:153:in `require'
        from
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/commands/server.r
b:49
        from
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
        from
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`require'
        from script/server:3


I tried this as well ruby script/server webrick
but did not succeed.

-- 
Posted via http://www.ruby-forum.com/.