Sundhari Bala wrote in post #1039108:
> Hi Luis,
>
> I am using Ruby 1.8.6 , gem 1.3.5 , rails 2.3.5 and Devkit 4.5.1
>
> Again i am getting this problem...
>
> Kindly help me.
>
>
> C:\Documents and Settings\Administrator>gem install facebook_oauth
> -v=0.3.0
> Temporarily enhancing PATH to include DevKit...
> Building native extensions.  This could take a while...
> ERROR:  Error installing facebook_oauth:
>         ERROR: Failed to build gem native extension.
>
> c:/ruby/bin/ruby.exe extconf.rb
> creating Makefile
>
> nmake
> 'nmake' is not recognized as an internal or external command,
> operable program or batch file.
>
>

Seems you didn't read my response.

The version of Ruby you're using (which is platform i386-mswin32) is 
expecting you have Visual Studio installed.

What you installed using RubyInstaller DevKit was GCC, which is not 
compatible with the version of the Ruby you have installed.

You need to use a version of Ruby provided by RubyInstaller *and* the 
DevKit.

The DevKit only works with GCC-compiled Ruby, not Visual Studio one.

So, if you execute this:

ruby -v

And see "i386-mswin32", DevKit will not work with that version of Ruby, 
period. There is nothing I can do to help you beyond what I've stated 
before: get RubyInstaller.

I can't help you further if you still have problems understanding what 
I've stated above.

--
Luis Lavena

-- 
Posted via http://www.ruby-forum.com/.