Sundhari Bala wrote in post #1039004:
> Hi ,
>
> I am using ruby 1.8.6 and rails 2.3.5 in windows..
>
> I have to install facebook_oauth gem, but i got below the error:
>
> C:\Documents and Settings\Administrator>gem install facebook_oauth
> -v=0.3.0
> Temporarily enhancing PATH to include DevKit...
> Building native extensions.  This could take a while...
> ERROR:  Error installing facebook_oauth:
>         ERROR: Failed to build gem native extension.
>
> c:/ruby/bin/ruby.exe extconf.rb
> creating Makefile
>
> nmake
> 'nmake' is not recognized as an internal or external command,
> operable program or batch file.
>
>

You've installed RubyInstaller DevKit (MinGW+MSYS) while the version of 
Ruby you have installed is looking for Visual Studio instead.

So: you're mixing a version of Ruby with the wrong compiler and by that, 
is not working.

Dunno where you obtained that version of Ruby (or how old is it) but you 
have two options:

A) Get Visual Studio for that version of Ruby

If is 'i386-mswin32' then you need Visual Studio 6.0, which is highly 
unlikely available free and online

B) Use RubyInstaller + RubyInstaller's DevKit instead

Removing that version of Ruby and use RubyInstaller, which is compiled 
with GCC and the DevKit is freely available.

All the information about RubyInstaller and the DevKit is available in 
the website where you obtained the DevKit.

I recommend you use latest Ruby 1.8.7 and DevKit 4.5.2

Good luck,
--
Luis Lavena

-- 
Posted via http://www.ruby-forum.com/.