Thank you very much for the prompt reply.

The response will be as follows:
------------------------------------------------------------
irb(main):001:0> require 'feed_tools'
/usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require':
iconv will be deprecated in the future, use String#encode instead.
SyntaxError:
/usr/local/lib/ruby/gems/1.9.1/gems/feedtools-0.2.29/lib/feed_tools/helpers/uri_helper.rb:43:
invalid multibyte char (US-ASCII)
/usr/local/lib/ruby/gems/1.9.1/gems/feedtools-0.2.29/lib/feed_tools/helpers/uri_helper.rb:43:
invalid multibyte char (US-ASCII)
/usr/local/lib/ruby/gems/1.9.1/gems/feedtools-0.2.29/lib/feed_tools/helpers/uri_helper.rb:43:
syntax error, unexpected $end, expecting ')'
          if IDN::Idna.toASCII('http://www..com/') ==
                                             ^
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
/usr/local/lib/ruby/gems/1.9.1/gems/feedtools-0.2.29/lib/feed_tools/helpers/retrieval_helper.rb:25:in
`<top (required)>'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
/usr/local/lib/ruby/gems/1.9.1/gems/feedtools-0.2.29/lib/feed_tools/feed.rb:27:in
`<top (required)>'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
/usr/local/lib/ruby/gems/1.9.1/gems/feedtools-0.2.29/lib/feed_tools.rb:170:in
`<top (required)>'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in
`require'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:59:in
`rescue in require'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in
`require'
        from (irb):1
        from /usr/local/bin/irb:12:in `<main>'
------------------------------------------------------------

Plus, after "gem install heroku", typed "heroku login"
the similar error message shows

/usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require':
cannot load such file -- readline (LoadError)
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from /usr/local/heroku/lib/heroku/command/run.rb:1:in `<top
(required)>'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from /usr/local/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from /usr/local/heroku/lib/heroku/command.rb:14:in `block in
load'
        from /usr/local/heroku/lib/heroku/command.rb:13:in `each'
        from /usr/local/heroku/lib/heroku/command.rb:13:in `load'
        from /usr/bin/heroku:26:in `<main>'

Any help appreciated please.