Luis Lavena wrote in post #1034729:
> You missed to tell Ruby's configure to use the $SANDBOX/usr location.
> ./configure --prefix=$SANDBOX/usr --with-opt-dir=$SANDBOX/usr
> Try again and let us know.
> --
> Luis Lavena

@luislavena: That was exactly the problem -- thank you.  I did the build 
from scratch (without installing readline) and everything seems to work 
okay.

SO TO RECAP: To build ruby-1.9.3-p0 under OS X 10.6.8, you need to load 
and install yaml-0.1.4 and configure the ruby build to use the yaml 
directory:

% SANDBOX=/Users/me/Developer/Sandbox
% PATH=${SANDBOX}/usr/bin:${PATH}

% # INSTALL YAML 0.1.4
% cd ../yaml-0.1.4
% ./configure --prefix=$SANDBOX/usr
% make install ; make clean

% # INSTALL RUBY
% cd ../ruby-1.9.3-p0
% ./configure --prefix=$SANDBOX/usr --with-opt-dir=$SANDBOX/usr
% make install ; make clean

% # UPDATE GEM
% gem update --system

-- 
Posted via http://www.ruby-forum.com/.