Thanks for your help. But as you said 1.9.2 does not need rdoc-data gem.
And I couldnt figure out how to generate documentation for it since I
installed via apt-get. So what I did is I cleaned all instances of ruby
and cleaned everything and I installed ruby via rvm. and used rvm to
generate the docs. Now ri works fine. Thanks a lot!!!

-- 
Posted via http://www.ruby-forum.com/.