Hi!

I have app, in which RMagick gem required (it place in bundle install).

But where I start it:

Installing rmagick (2.13.1) with native extensions
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native
extension.

/usr/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... yes
checking for ImageMagick version >= 6.4.9... yes
checking for HDRI disabled version of ImageMagick... yes
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
Package MagickCore was not found in the pkg-config search path.
Perhaps you should add the directory containing `MagickCore.pc'
to the PKG_CONFIG_PATH environment variable
No package 'MagickCore' found
checking for stdint.h... /usr/lib/ruby/1.9.1/mkmf.rb:368:in `try_do':
The complier failed to generate an executable file. (RuntimeError)
You have to install development tools first.
  from /usr/lib/ruby/1.9.1/mkmf.rb:452:in `try_cpp'
  from /usr/lib/ruby/1.9.1/mkmf.rb:834:in `block in have_header'
  from /usr/lib/ruby/1.9.1/mkmf.rb:693:in `block in checking_for'
  from /usr/lib/ruby/1.9.1/mkmf.rb:280:in `block (2 levels) in postpone'
  from /usr/lib/ruby/1.9.1/mkmf.rb:254:in `open'
  from /usr/lib/ruby/1.9.1/mkmf.rb:280:in `block in postpone'
  from /usr/lib/ruby/1.9.1/mkmf.rb:254:in `open'
  from /usr/lib/ruby/1.9.1/mkmf.rb:276:in `postpone'
  from /usr/lib/ruby/1.9.1/mkmf.rb:692:in `checking_for'
  from /usr/lib/ruby/1.9.1/mkmf.rb:833:in `have_header'
  from extconf.rb:193:in `<main>'


Gem files will remain installed in
/usr/lib/ruby/gems/1.9.1/gems/rmagick-2.13.1 for inspection.
Results logged to
/usr/lib/ruby/gems/1.9.1/gems/rmagick-2.13.1/ext/RMagick/gem_make.out
An error occured while installing rmagick (2.13.1), and Bundler cannot
continue.
Make sure that `gem install rmagick -v '2.13.1'` succeeds before
bundling.

>

I can't find something similar to it in google.

Plz help!

-- 
Posted via http://www.ruby-forum.com/.