On Fri, Nov 18, 2011 at 9:27 PM, john john <tpclhk / gmail.com> wrote:
> Hello, sorry I'm new to ruby. I have got ruby and some gems on my mac
> installed.
> Then I run this:
> sh-3.2# ruby myrubyserver.rb
>
> And get this:
> /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/r=
ubygems/custom_require.rb:31:in
> `gem_original_require': no such file to load -- cfpropertylist
> (LoadError)
> =A0from
> /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/r=
ubygems/custom_require.rb:31:in
> `require'
> =A0from siriserver.rb:5
>
> How can I solve this problem? I googled everywhere but I couldn't find
> one that can solve my problem.
> Thanks!

Try running
    sudo gem install CFPropertyList

Pay attention to where it says things like "`gem_original_require': no
such file to load - cfpropertylist". That means you're missing a
library file called cfpropertylist. You can either Google that name
(possibly with other keywords like "ruby" or "gem"), search for it on
rubygems.org, or type
    gem list --remote cfpropertylist
or
    gem search --remote cfpropertylist

That will tell you the name of the gem to install. In this case, this
is helpful, because gem install is case-sensitive and the
CFPropertyList gem has mixed case. In many cases, though, the name of
the missing require file is the same as the name of the gem.

Hope this helps.