what's your full error output?
for me, works with
gem install mysql2 -- --with-mysql-dir=c:\installs\mysql-5.5-11

-- 
Posted via http://www.ruby-forum.com/.