Hi guys!

So I've just installed DevKit successfully and have passed the
installation test (5. TEST INSTALLATION) as recommended by this web
page:

https://github.com/oneclick/rubyinstaller/wiki/Development-Kit

Now I'm following a book that suggests I "install the redcloth gem, a
library that can convert specially formatted text into HTML, ready to be
used on a Web page."

Please note that there are already RedCloth files in my Ruby
installation directory because when I first went into this gem
installation tutorial, I didn't know I had to install DevKit first.  So
I installed RedCloth before the Devkit.

I had problems with the RedCloth installation of course, but now that I
already have the right version of Devkit installed, I figured I'd
install RedCloth again, assuming that all those RedCloth files will be
overwritten and everything will be fine.

This is what I got:

C:\Users\Kaye>gem install RedCloth
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
Successfully installed RedCloth-4.2.8
1 gem installed
Installing ri documentation for RedCloth-4.2.8...
Installing RDoc documentation for RedCloth-4.2.8...

C:\Users\Kaye>testgem
<internal:lib/rubygems/custom_require>:29:in `require': no such file to
load --
1.9/redcloth_scan (LoadError)
Couldn't load 1.9/redcloth_scan
The $LOAD_PATH was:
C:/Ruby192/lib/ruby/gems/1.9.1/gems/RedCloth-4.2.8/bin
C:/Ruby192/lib/ruby/gems/1.9.1/gems/RedCloth-4.2.8/lib
C:/Ruby192/lib/ruby/gems/1.9.1/gems/RedCloth-4.2.8/lib/case_sensitive_require
C:/Ruby192/lib/ruby/gems/1.9.1/gems/RedCloth-4.2.8/ext
C:/Ruby192/lib/ruby/site_ruby/1.9.1
C:/Ruby192/lib/ruby/site_ruby/1.9.1/i386-msvcrt
C:/Ruby192/lib/ruby/site_ruby
C:/Ruby192/lib/ruby/vendor_ruby/1.9.1
C:/Ruby192/lib/ruby/vendor_ruby/1.9.1/i386-msvcrt
C:/Ruby192/lib/ruby/vendor_ruby
C:/Ruby192/lib/ruby/1.9.1
C:/Ruby192/lib/ruby/1.9.1/i386-mingw32
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from
C:/Ruby192/lib/ruby/gems/1.9.1/gems/RedCloth-4.2.8/lib/redcloth.rb:
12:in `<top (required)>'
        from <internal:lib/rubygems/custom_require>:33:in `require'
        from <internal:lib/rubygems/custom_require>:33:in `rescue in
require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from G:/Ruby/Practice/testgem.rb:2:in `<main>'

-------------------------------------------------------------------------------

Why 'no such file to load'?
I made the testgem.rb to test if RedCloth was installed properly.
testgem.rb is saved on my thumb drive (G:), as you can see on the last
line.

Help please?

Thanks guys!!!

-- 
Posted via http://www.ruby-forum.com/.