Hello!

> Dunno why you keep attempting to use 3.4.5 version.

In https://github.com/oneclick/rubyinstaller/wiki/Development-Kit , it says:

"For RubyInstaller°«s previous to 1.9.2-p0 you may feel more comfortable using the DevKit-3.4.5-CCYYMMDD-sfx.exe as the earlier RubyInstallers were built using MSys/MinGW v3.4.5. "

My Ruby is 1.9.2-p0 and that is why I chose DevKit 3.4.5

> While the gist is particular to my system and installing rdiscount, I
> suspect that your operating_system.rb doesn't look like what's shown.

I found operating_system.rb at C:\Ruby192\lib\ruby\1.9.1\rubygems\defaults , opened it with SciTE:

# override 'gem install' to enable RubyInstaller DevKit usage
Gem.pre_install do |i|
  unless ENV['PATH'].include?('C:\\DevKit\\mingw\\bin') then
    puts 'Temporarily enhancing PATH to include DevKit...'
    ENV['PATH'] = 'C:\\DevKit\\bin;C:\\DevKit\\mingw\\bin;' + ENV['PATH']
  end
end

I guess you're right, Jon? It doesn't look like yours.
Would you mind explaining its significance?

> Show the results for Luis' question by changing to your C:\DevKit
> directory and running "ruby dk.rb install"

The result is:
C:\DevKit>ruby dk.rb install
[INFO] RubyGems override already in place for C:/Ruby192, skipping.
[WARN] DevKit helper library already exists for C:/Ruby192, skipping.

I guess that's because I've already installed dk.rb?
Or should I uninstall Ruby and DevKit and starch from scratch?

Thank you!