> |I do a lot of incrementing and decrementing of values: it'd be nice if
> |Numeric#succ had a counter part.
> |
> |The attached patch provides Numeric#prev which is faster in tight
> |loops than (one less object):
> 
> I think you meant Integer#prev.

Yes, sorry: the edit is in numeric.c.  :~)

> I'm not sure how much useful it is.  And I'm (little bit) afraid of
> it might cause request for String#prev, which is way difficult to
> define.

It's only as useful as Integer#succ, which, proves to be useful when
dealing with simple stacks and counters used outside of the range
class.  I agree with the preceding post:

aString.succ.prev  = aString.prev.succ = aString

-sc

-- 
Sean Chittenden