thanks for the suggestion, although i should have figured that one out 
myself!

i upgraded gcc and ruby-1.9.3 compiled fine!   strangely, ruby-1.9.2 
kept giving some sort of corrupt memory error.   but i am counting this 
one as a success.

-- 
Posted via http://www.ruby-forum.com/.