On Fri, Sep 16, 2011 at 1:42 PM, Chad Perrin <code / apotheon.net> wrote:
> On Fri, Sep 16, 2011 at 10:55:03AM +0900, brabuhr / gmail.com wrote:
>> On Thu, Sep 15, 2011 at 3:03 PM, Chad Perrin <code / apotheon.net> wrote:
>> > I have not been able to get readline working with the 1.9.3 preview using
>> > RVM.
>> >
>> > I did, by the way, try following the instructions at the referenced URI
>> > (replacing "1.9.2" with "ruby-1.9.3-preview1").   
>> > suggestions on how to resolve this problem would be appreciated.
>>
>> $ uname -a
>> Darwin Mac-mini.local 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun 
>> 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386
>
> Linux hemlock 3.0.0-1-amd64 #1 SMP Sat Aug 27 16:21:11 UTC 2011 x86_64
> GNU/Linux
>
>  ruby -v -e "p require 'readline'"
>  Ɱ   ߶
> home/user/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- readline (LoadError)
>  >  庱

Thanks; trying again on another host:

[same rvm process]

$ uname -a
Linux linux116.ctc.com 2.6.32-131.6.1.el6.x86_64 #1 SMP Tue Jul 12
17:14:50 CDT 2011 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/redhat-release
Scientific Linux release 6.1 (Carbon)

$ ruby -v -e "p require 'readline'"
ruby 1.9.3dev (2011-07-31 revision 32789) [x86_64-linux]
true

I still don't know what's going on then, sorry.

> Elided output is here (plus the require 'readline' output):
>
>  𺯯Ʊ