Jon Forums wrote in post #1022204:
>> FYI, the 2.0.0pre branch of Rubinius has been merged back to master. The
>> 1.2.5 branch is available too, but everyone should be using the master
>> branch at this point. It can be built to handle both 1.8 and 1.9 syntax
>> (though the 1.9 syntax is incomplete).
>>
>> Pop into the #rubinius channel on freenode and we'll lend you a hand
>> getting it compiled and running.
>>
>> cr
>
> Chuck,
>
> Due to work issues, sadly it's been a few weeks since I've tried (and
> failed) to build 2.0.0pre (zlib dep and segv issues), but are you aware
> of
> anyone building the current master for Windows on Windows (mingw-w64 and
> friends), not a VM?
>
> Jon

Chuck,

Nevermind, just tried building master this morning and after manually
applying

  https://github.com/rubinius/rubinius/pull/1108

my MRI 1.9.3 build ruby get's segfaulted in `melbourne.rb` via native
`:file_to_ast_19` it seems

  https://gist.github.com/1222357

Will try another time with 1.8.7 and swing over to #rubinius to see if
there's any adventurous souls.

If you've got any interest, how about setting up a Win7 VirtualBox guest
on your (OSX?) system, build via a name-prefix stripped mingw-w64 DevKit
like

  http://jonforums.github.com/ruby/2011/07/17/building-rubinius-on-windows-1.html

and see how far you get.


Jon

---
blog: http://jonforums.github.com/
twitter: @jonforums

"Anyone who can only think of one way to spell a word obviously lacks
imagination." - Mark Twain

-- 
Posted via http://www.ruby-forum.com/.