On Sep 9, 2011, at 11:14 PM, mark e. wrote:

> ...
> i looked into rvm, but it required a newer version of BASH and git 
> (whatever that is)
> 
> it seemed easier just to build on my own.   but i may have to revisit 
> rvm.
...

I strongly urge you to install rvm.
It is an incredibly useful tool.
Well worth the trouble to set up if you plan
to write anything beyond "Hello World!" or
similarly simple programs in ruby.

Dan Nachbar