Hi hex,

I doubt of installing gtk2 again.

So, could you confirm the following?

- just open IRB
- input `require 'gtk2'`
- get `=> true`

I guess you'll get some error messages.

ps. I cloned serialhex/fun-stuff and ran spaceship_earth.rb on my Windows 7.
It worked well. ;-)

ashbb