On 8/18/2011 09:23, reed das wrote:
> $ rvm install ruby-1.9.2
> $ rvm rubygems 1.8.8
> ERROR: 'ruby' was not found, cannot install rubygems unless ruby is
> present (Do
> you have an RVM ruby installed & selected?)
                                   ^^^^^^^^

After installing a ruby using rvm, you need to tell rvm to use it.
Assuming you have your shell configured correctly as documented on the
rvm homepage, run this:

$ rvm use ruby-1.9.2

At this point, you should have the gem command available since rubygems
is integrated with ruby-1.9.2.  You may then choose to upgrade rubygems
if you wish.

-Jeremy