Is there something changed between 1.9.2 and 1.9.3-preview1 in
Test::Unit and/or rake?

I have this in my Rakefile, works fine in 1.9.2-p290 and fails in
1.9.3-preview1...

desc "Run basic tests"
Rake::TestTask.new("test_units") { |t|
  t.pattern = 'test/test_*.rb'
  t.verbose = true
  t.warning = true
}

1.9.2:
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.2-p290/bin/ruby -w -I"lib"
-I"/Volumes/Users/roberto/.rvm/gems/ruby-1.9.2-p290 / ruby-1.9.2-p0/gems/rake-0.9.2/lib"
"/Volumes/Users/roberto/.rvm/gems/ruby-1.9.2-p290 / ruby-1.9.2-p0/gems/rake-0.9.2/lib/rake/rake_test_loader.rb"
"test/test_*.rb"
Loaded suite
/Volumes/Users/roberto/.rvm/gems/ruby-1.9.2-p290 / ruby-1.9.2-p0/gems/rake-0.9.2/lib/rake/rake_test_loader
Started
..................................................................................
Finished in 0.081080 seconds.

82 tests, 494 assertions, 0 failures, 0 errors, 0 skips

1.9.3:
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:167:in
`block in non_options': file not found: test/test_*.rb (ArgumentError)
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:146:in
`map!'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:146:in
`non_options'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:207:in
`non_options'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:52:in
`process_args'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/minitest/unit.rb:891:in
`_run'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/minitest/unit.rb:884:in
`run'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:21:in
`run'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:326:in
`block (2 levels) in autorun'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:27:in
`run_once'
  from
/Volumes/Users/roberto/.rvm/rubies/ruby-1.9.3-preview1/lib/ruby/1.9.1/test/unit.rb:325:in
`block in autorun'
rake aborted!

-- 
Posted via http://www.ruby-forum.com/.