On 11-07-21 11:00 PM, Eric Hodel wrote:
> On Jul 21, 2011, at 6:25 PM, Dev Guy wrote:
>> my output is (not sure why I got 1.9.1 in there???)
> 1.9.1 is the API compatibility version.  1.9.1 is expected.
>
>> ["/usr/local/lib/ruby/gems/1.9.1/gems/rdoc-3.8/lib/rdoc/generator.rb",
>> "/usr/local/lib/ruby/gems/1.9.1/gems/rdoc-3.8/lib/rdoc/generator/markup.rb",
>> "/usr/local/lib/ruby/gems/1.9.1/gems/rdoc-3.8/lib/rdoc/generator/darkfish.rb",
>> "/usr/local/lib/ruby/gems/1.9.1/gems/rdoc-3.8/lib/rdoc/generator/ri.rb",
>> "/usr/local/lib/ruby/gems/1.9.1/gems/horo-1.0.3/lib/rdoc/generator/horo.rb"]
> You can work around this by uninstalling horo or RDoc 3.8 and reinstalling after completing the upgrade to 1.9.2-p290.
>
> I'm not sure how to fix the actual issue in an easy way.
>
> The problem is this:
>
> RDoc 2.5.8 comes with Ruby 1.9.2
>
> RDoc 2.5.8 will try to load plugins when rdoc/rdoc is loaded.
>
> The plugin horo activates the RDoc gem, then requires rdoc/rdoc again redefining methods that won't work with the objects created before the plugin load.
>
> Could you add a ticket to redmine.ruby-lang.org and assign it to me?
>
> It should say "RDoc should not load plugins when building ri data"
workaround fixed my issue. i've opened a new ticke and assigned it too 
you, thanks for your help!

...now I got an issue with rails...don't think it's related to this!

-- 
Kind Regards,
Rajinder Yadav | http://DevMentor.org | Do Good! ~ Share Freely