IT seems closer to map than zip (IMHO) so maybe map_with ?
OR would cross_product cover it? Maybe too specific...

On Sun, Jul 17, 2011 at 9:44 PM, Intransition <transfire / gmail.com> wrote:
> Any ideas for a better name for:
>
> =A0 =A0[1,2,3].zip_with([6,5,4]) { |a, b| 3 * a + b } #=3D> [9, 11, 13]
>
> #zip_with comes from Haskell, but I think it's confusing because of
> Ruby's #zip.
>
>
>