On Fri, Jul 15, 2011 at 8:37 AM, Austin Ziegler <halostatue / gmail.com> wrote:
> Sadly, JRuby in 1.9 mode won't work because of an apparent bug in
> JRuby itself, and "jruby --1.9 -S rake test" only looks like it works
> because the test actually runs JRuby again in 1.8 mode. A bug has been
> filed for the former case, but an improvement has not yet been filed
> for the latter case.

Ok, I see your bugs. We'll have a look into it.

FWIW, you can specify JRUBY_OPTS=--1.9 and it will pass through to the
child JRuby instances too. But I agree, we need a dotfile or similar
to force it.

- Charlie