Hi,

In message "Re: RFC - One word alias for require_relative"
    on Sat, 18 Jun 2011 06:40:36 +0900, Ilias Lazaridis <ilias / lazaridis.com> writes:

|Solutions:
|
|require! 'lib/alter' # 2011-06-17 by Gary Wright
|involve  'lib/alter' # 2011-06-16 by Sam Duncan
|locally  'lib/alter' # 2011-06-11 by Rob Biedenharn
|uniload  'lib/alter' # my
|request  'lib/alter' # my
|include  'lib/alter' # my
|relative 'lib/alter' # my

|I like the word "involve" more, but as "require!" reminds clearly the
|original "require", it's the first choice.

Unfortunately the general rule for the "!" in the method name, at
least in the standard library, is that it means "more dangerous than
the version without bang".  Since require! does not follow this rule,
and not worthy to change the rule.  So it's no chance to have require!
in the standard library.

							matz.