I can't believe I'm adding to this conversation... 

Ruby already has an idiom for naming two related methods so how about:

require "a/b"        # the usual
require! "a/b"       # require relative to __FILE__