Hello everyone :)

I progressed in my business, I understood the principle of external
library like zlib (actually it makes sense, I was a bit stupid on
that!). So I tried to install RVM, but I failed: the RVM script doesn't
work, certainly because I'm behind a proxy, but I did not pursue because
I wanted to try to install "mkmf" (it was the error that caused the
installation failed of metric_fu) and it worked! :)

Now metric_fu is installed correctly but I can't make it work: I make
the "Rakefile" file with just "require 'metric_fu'" inside, and when I
type "rake1.9.1 metrics:all" I get that :

"
root@Alexis-VBox-Ubuntu:~/Ruby/Cinetheque# rake1.9.1 metrics:all
(in /home/alexis/Ruby/Cinetheque)
rake aborted!
No such file or directory - churn --yaml
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/lib/generators/churn.rb:10:in
``'
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/lib/generators/churn.rb:10:in
`emit'
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/lib/base/generator.rb:130:in
`block in generate_report'
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/lib/base/generator.rb:128:in
`each'
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/lib/base/generator.rb:128:in
`generate_report'
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/lib/base/report.rb:60:in `add'
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/tasks/metric_fu.rake:6:in
`block (3 levels) in <top (required)>'
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/tasks/metric_fu.rake:6:in
`each'
/var/lib/gems/1.9.1/gems/metric_fu-2.1.1/tasks/metric_fu.rake:6:in
`block (2 levels) in <top (required)>'
/usr/lib/ruby/1.9.1/rake.rb:634:in `call'
/usr/lib/ruby/1.9.1/rake.rb:634:in `block in execute'
/usr/lib/ruby/1.9.1/rake.rb:629:in `each'
/usr/lib/ruby/1.9.1/rake.rb:629:in `execute'
/usr/lib/ruby/1.9.1/rake.rb:595:in `block in invoke_with_call_chain'
/usr/lib/ruby/1.9.1/monitor.rb:201:in `mon_synchronize'
/usr/lib/ruby/1.9.1/rake.rb:588:in `invoke_with_call_chain'
/usr/lib/ruby/1.9.1/rake.rb:581:in `invoke'
/usr/lib/ruby/1.9.1/rake.rb:2041:in `invoke_task'
/usr/lib/ruby/1.9.1/rake.rb:2019:in `block (2 levels) in top_level'
/usr/lib/ruby/1.9.1/rake.rb:2019:in `each'
/usr/lib/ruby/1.9.1/rake.rb:2019:in `block in top_level'
/usr/lib/ruby/1.9.1/rake.rb:2058:in `standard_exception_handling'
/usr/lib/ruby/1.9.1/rake.rb:2013:in `top_level'
/usr/lib/ruby/1.9.1/rake.rb:1992:in `run'
/usr/bin/rake1.9.1:31:in `<main>'
"

Is there someone using metric_fu who knows the problem?

Thank you again!
Alexis

-- 
Posted via http://www.ruby-forum.com/.